KMSYS Worldwide, Inc.

eQuate Installation and Quick Start

This is a step-by-step guide to install and start using eQuate. This guide will not
show the full application or features of the product, but will help in getting started.
If you have any questions or problems, please contact us.
(770) 635-6363
support@kmsys.com

Introduction
Previous versions of eQuate offered two separate installations: eQuate Developer
Edition and eQuate User (Session Manager). The Developer Edition would be
installed locally on the developer’s PC and the eQuate Session Manager on each
individual user’s PC. eQuate requires the eQuate Administrator to place the eQuate
runtime files on a common server. All configuration for the end users (routes,
station names, host IP addresses, etc.) is done by the eQuate Administrator and
maintained locally, then “published” (see Publishing and Run-time Options, below) to
the server along with the eQuate Application Databases. The End User runs the
eQuate Session Manager from a standalone program installed locally or from a Web
page utilizing eQuate Web.
NOTE: The standalone eQuate Session Manager is installed with the development
edition of eQuate and may be used to “quick test” your eQuate Application
development efforts. The standalone session manager is available as an optional
install for end users but is not required when using eQuate Web.
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The eQuate Database and Applications
An eQuate Database is a collection of files including a single user registration
database and one or more eQuate application databases. The databases are made
up of source files (.DBF, .MDX and .DBT) and runtime files (.RTF, .ACT and .BFM).
The user registration database is located in a base directory determined by the
eQuate Administrator program. Also in that directory, there will be one subdirectory
for each eQuate application database created. The application’s database files reside
in that subdirectory. The name of the subdirectory is the name you give the
application in the eQuate Administrator program (see Quick Start, Step 2, below).

The Demo Database
During the installation process, there will be an opportunity to install a demo
database from KMSYS Worldwide. The eQuate Demo Database has examples of an
eQuate Application that was developed in-house at KMSYS Worldwide. If you would
like to examine the eQuate Demo Database, you may do so immediately after
installing eQuate (Steps 1, below) without completing the remainder of the Quick
Start steps; however, you should return and complete the Quick Start procedure to
establish your own eQuate database. To examine or run the application and forms of
the eQuate Demo Database, use the default user id, ADMIN, and password, EQUATE.

Quick Start
Use the following procedure to initially install and create an eQuate database and
application:
1. Install the eQuate Developers’ Edition using the CD, diskettes or files that
were downloaded. Run setup.exe and follow the instructions to install the
product.
Note: eQuate is initially installed on the developer’s PC. Once an eQuate
application has been developed and is ready for implementation, the
Administrator program will be used to distribute that application, along with
the necessary programs, to a shared file server.
2. Run the administration program from the Windows Start menu (from the
Windows Taskbar, select Start | Programs | KMSYS Worldwide | eQuate |
Administrator). The default User Id and Current Password are ADMIN and
EQUATE, respectively. Once the administration program is open, you can add
a new user id for yourself and delete or change the default ADMIN user id.
Note: Any new user id added will have an initial password of EQUATE but may
be changed with the Administrator program.
The next step is to create an Application Database. Choose the Database
Management tab and select Application Database as the Database Type.
Next, click the New Database button to initialize the database files necessary
to create applications. You will be prompted to name the database directory.
This name is only visible to eQuate Administrators and Developers allowing
them to group databases with logical names. Once this step is completed,
you will see a list of eQuate application database files that were initialized and
you can close the Administrator program.
3. Now, run a WinQ Configuration program from the Windows Start menu.
There are two different programs. If your host is a Unisys Clearpath Plus OS
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2200 Server, run the WinQ UTS Config program. If your host is a Unisys
Clearpath Plus MCP Server, select WinQ T27 Config. You will need to set up
at least one connection to your host at this point. Also, note the Route Name,
as it will be needed when the eQuate Session Manager is first run.
From the main WinQ Configuration window, select Open from Default Location
from the File menu. Next, click the Configure Connections button. From the
Configure Connections window, use the control to setup routes to your
particular host(s). Note: Select Contents from the Help menu to receive
instructions on how to use these controls. When you have completed the
necessary routes, click the Save and Close button.
From the File menu, select Save To and choose a location where you wish to
maintain the WinQ configuration files. This location should be in a non-shared
location. Later in this procedure, the publish function will copy these files to a
shared file server. The location chosen must have a sub directory that is
either “T27” or “UTS” depending on the type of host connection required. It
is into one of these two directories that you save the WinQ configuration. You
may use the defaults %APPDATA%\KMSYS
Worldwide\eQuate\3.50\Connections\T27 or %APPDATA%\KMSYS
Worldwide\eQuate\3.50\Connections\UTS, where the system variable,
%APPDATA%, represents the drive and path to the Windows "Application
Data" folder.
4. Run the Capture program from your Windows Start menu. This program will
allow the eQuate Administrator or Developer to capture screens from the
built-in emulator and create Windows-like forms. The first step is to open the
terminal to establish your connection to the host. If you used the “Save To”
option suggested in the previous step, select the Alternate location option
prior to clicking the Open Routes button. When the Select Alternate
Connections Directory dialog appears, you will be able to select the directory
where you saved the WinQ Configuration. Next, select the configured route
and click the OK button. Once connected and signed on, navigate to the
screen you want to capture and click the Capture Screen button on the
eQuate Form Capture window. The Capture program will read the current
screen and create a basic form. Next, click the Generate Form Definition
button and save it to a file to be used later. You can repeat these steps to
capture as many screens as you want before exiting.
Note: If your host is a 2200 and your screen definitions are stored in a DPS
form file, you may skip the capture step and import the form definitions from
downloaded files created by DPS’s Form Language Manipulation Utility
(@FLMU,F). These files may be imported directly into the eQuate Application
Manager. The following is an example of the execution of the FLMU processor
and editing the result:
X@ASG,A TEMP.
XI:002333 ASG complete.
X@USE SCREEN$OMN.,TEMP.
XI:002333 USE complete.
X@FLMU,F your-form-file.
XFLMU 6R4NQ1 6-8-56 Form Language Manipulation Utility 2007 Feb 15 Thu 1008:03
XENTER FORM NUMBER
X75
X
1 FORMS CONVERTED TO FLDP SOURCE.
XENTER FORM NUMBER
X@EOF
XFLMU COMPLETE
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X@ED,R TEMP.FLDP-75

5. Open the Application Manager from the Windows Start menu. Select the
database that was created in the Administration program. Next, choose the
Applications tab and add a new application. You will need to give the
application a name that both the administrator and users will access. This
will also prompt you for the terminal type (UTS or T27) and other information
that is used for that application.
Once the Application is created, you can start to import the forms that were
created in the Capture program or downloaded from a DPS form file. Move to
the Forms tab and add a form. If you are importing forms captured or
downloaded previously, click the Import Form button and open the saved file.
Important: Next, give the form a Form Name and select a Form Id String. A
Form Id is needed for each form to allow eQuate to recognize which form is
needed by comparing a string on the terminal screen to the one you define
for the form.
Click the Form Design button to customize your forms, add and delete
controls and menu items, add actions and more. The eQuate Form Designer
is a VB-like development environment where you add or select a Windows
control and specify what action is to take place when the user selects that
control at run time. Note: For tips and examples, be sure to read the on-line
help for the eQuate Form Designer.
The final step in creating your application for the user’s to access is to create
run-time files. When you exit the Application Manager, the run-time files are
automatically saved, or you may select File | Create Run-time Files Now from
the eQuate Application Manager Window. Creating run-time files separate
from the design database files allow simultaneous development and execution
of eQuate applications. Furthermore, run-time files are the only files
accessed by the users when they run the Session Manager. The database
design files will never be accessed by the user for reasons of security.
6. Once again, return to the Administration program. Each user will need to be
granted access to the applications. Select the user and press the Edit Profile
button to add the new application to the user’s profile.
After the user has been assigned the proper applications, you will also need to
assign a sign-on script to each application. The sign-on script allows the user
to connect to the host when the application is initially started by the eQuate
Session Manager. Two general-purpose scripts are provided by KMSYS
Worldwide: soT27.bas for MCP access and soUTS.bas for 2200 access.
Initially, they reside in the “Scripts” directory on the local PC where the
eQuate Developers’ Edition was installed (see %APPDATA%\KMSYS
Worldwide\eQuate\3.50\Scripts, where the system variable, %APPDATA%,
represents the drive and path to the Windows "Application Data" folder). You
may alter a copy of these scripts to fit the specific requirements of your site;
however, they were written in a manner to function properly without
modification at most sites.
Once all the applications have been assigned to the users, the run-time files
should be automatically created when exiting the Administration program.
7. The Session Manager is ready to be run. The installation of the eQuate
Developers’ Edition will install all the necessary files to run the Session
Manager.
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The Session Manager has two directories that will need to be configured from
the File menu upon first use. The Run-Time Directory is the directory from
which you will test the eQuate application (default, %APPDATA%\KMSYS
Worldwide\eQuate\3.50\Data, where the system variable, %APPDATA%,
represents the drive and path to the Windows "Application Data" folder). For
this “Quick Start” procedure, it is initially on the developer’s PC. Later, when
the eQuate application is ready for production, the eQuate Administrator
program will be used to “publish” the application which will distribute it to a
shared file server (see below). The Script Directory is the location of the
sign-on scripts that are used to connect to the host. This directory can also
be on the computer’s hard drive or a file server. Both of these directories are
created during installation for first time installs.
Finally, select Profiles from the File menu and assign a Route to the eQuate
Application. This step is not required if you assigned a Connection Route to
the application in the Application Manager, or if you simply wish to override
that setting.

Publishing and Run-time Options
When it is time to give users access to an eQuate application, use the eQuate
Administrator program to distribute all the run-time files to a shared server. Use the
following procedure to publish eQuate Application Databases to a shared server:
On the eQuate Administrator dialog, select the Run-Time Publish tab. Use the
select buttons to set the source and destination locations where you maintain
your eQuate Database (includes user registration configuration and eQuate
Application Databases) and run-time scripts. Click the copy buttons to
distribute the run-time files to the network server.
Note: Users must have read access to the four “Destination” directories.
Note2: Regardless of whether your users are to execute the standalone
eQuate Session Manager or run it from a Web page utilizing eQuate Web,
always use this step to distribute the directories.
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